Fixing My Asus AiMesh Node Drops

I’ve been generally happy with my AiMesh system, even extending it to my mother’s house on our property.  However, we’ve had the occasional node drop from the system and it has become more and more frequent, requiring a reboot of the node to bring it back.

Oddly, the IP address of the off-line node could still be pinged and ssh’d into, but the clients connected would drop and it would show off-line in the router administration page.

After a lot of internet searching with only clues and no real solutions, I started looking at the logs and how they nodes were connecting to each-other.  Some things were readily apparent and helped resolve this:

  1. Location! Location! Location! I downloaded the Asus app which actually showed me how the nodes connected to each other. For some reason the web page for the router does not include this valuable information. In the picture below, you can see how the nodes are connected currently. The node in the middle is in the garage connected via Ethernet and feeding the two “below” which are over at mom’s house wirelessly. The node with the chair on it is in our living room and geographically next closest to the garage node. What was happening was the signal strength between the living room and garage was in the threshold of “good enough” causing the two wireless nodes to “hop” back and forth continuously between the two. I assume eventually, they’d get dropped by a confused system. I moved the living room node just a bit further away and the situation improved.
  2. Roaming Assistant. In the router’s web-app, under Wireless and Professional tab is this setting. I changed this value from the default settings of both 2.4GHz and 5GHz to 62dBm. This forces clients and nodes to connect to access points offering what we see is “about 3 bars” on our devices, if available. This caused the hopping nodes to zero-in on the better node and stay connected. I’ve had no drops since this change.
  3. Airtime Fairness. Also in the same section above, I’ve read that Disabling this feature can fix some issues. I have set that initially and noticed maybe some difference, but for me I consider this a minor contributing factor of the improvement.

So, the AiMesh system can be very robust and stable, but it isn’t quite the out-of-the-box set-and-forget-system they claim. Perhaps I, and the others with nodes dropping, are edge cases with a lot of wifi traffic and heavy use. If you’ve stumbled across this, hopefully this helps!

This entry was posted in General Happenings. Bookmark the permalink.

One Response to Fixing My Asus AiMesh Node Drops

  1. Sid says:

    Stumbled upon this with a similar issue. Thanks for the writeup, worked wonders! I initially was looking for a cron script to reboot the node, but this worked and was much much simpler!

Leave a Reply

Your email address will not be published. Required fields are marked *